Labelling rules being ignored

I have two subprojects. Each has a Subversion VCS root of /.../svn/head1/head2/projecti/trunk. I have tried a variety of correct and syntactically incorrect labelling rules, both absolute and relative. In every case, when I try to (manually) label a build, I get

Labeling process failed: Labeling the path 'head1/head2/projecti/trunk/trunk' to 'head1/head2/projecti/trunk/tags/build-25' has failed with the error: svn: Path trunk does not exist in revision 2169

Some of the rules that I've tried:

.=>../tags

/svn/head1/head2/projecti/trunk=>/svn/head1/head2/projecti/tags

/head1/head2/projecti/trunk=>/head1/head2/projecti/tags



I have verified that both subprojects' VCS roots are configured with labeling rules, but these rules are being ignored. What do I need to do?

Thank you,
Steve Schwartz

Edited by: Steve Schwartz on Oct 24, 2008 2:32 PM

3 comments
Comment actions Permalink

Steve,

Sorry for the delay in replying.

Could you please specify the full URL you have in the VCS root and the URL of the root of the Subversion repository?

Provided Subversion repository root URL is http://svn.jetbrains.org/teamcity
The following settings should work:

VCS root URL: http://svn.jetbrains.org/teamcity/plugins/clearcase-vcs/trunk/
Labeling rules: /plugins/clearcase-vcs/trunk=>/plugins/clearcase-vcs/tags

-or-

VCS root URL: http://svn.jetbrains.org/teamcity/plugins/clearcase-vcs/
Labeling rules: trunk=>tags


--
Best regards,

Yegor Yarko
Project Manager (TeamCity)
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Hey,

I am having trouble with the SVN Labelling.

I have the following structure setup:

SVN Root: http://ourdomain/svn/
VCS URL:  http://ourdomain/svn/LRS/trunk

Labelling rules - /LRS/trunk=>/LRS/tags

However every time i try to label a build i get the following error:

Labeling process failed: Labeling the path 'trunk/trunk' to  'trunk/tags/build-20' has failed with the error: svn: Path trunk does  not exist in revision 5217

no matter what i change my labelling rules to, i get the same error, its likes its not picking up on changes to my labelling rules

I am currently using 6.5.3 (build 17985)

any help would be great thanks.

P.S find attached is a screenshot of my repository root, vcs settings and error messgae i am getting.

Cheers,
Thomas



Attachment(s):
labellingBuildError.doc
0
Comment actions Permalink

I cannot reproduce it so far.
please let me know if the issue is still actual, and we'll figure this out.

Michael

0

Please sign in to leave a comment.