VS2010 integration - setting up subversion - Unable to use executable file

Hi,

I was trying to setup Teamcity to use Subversion source control - but then I had to add a subversion client (could not use Turtoise), so I installed the one from collabnet (1.7.1) but got this error when trying to setup spesific path to svn.exe :

---------------------------
TeamCity
---------------------------
Unable to use executable file from “C:\Program Files (x86)\CollabNet\Subversion Client\svn.exe”.
Version (1.7.1) of specified Subversion client “C:\Program Files (x86)\CollabNet\Subversion Client\svn.exe” is not supported.
---------------------------
Retry   Cancel   
---------------------------

Any idea what the problem might be here?



Attachment(s):
TeamCityVS2010SubversionSetup.JPG
3 comments
Comment actions Permalink

Hi Jens

Subversion 1.7 is not supported by TeamCity 6.5 - it was released months later than our release.
You'll need to switch to Subversion 1.6.

VS Addin in upcomming version 7.0 will support SVN 1.7.

Michael

0
Comment actions Permalink

ok, thanks - I didn't figure they were so closely integrated that I need another version of TeamCity in order to use svn 1.7... - when is Teamcity 7 due?

0
Comment actions Permalink

At the moment we're targeting to Q1 2012.

0

Please sign in to leave a comment.