Error while applying patch: Failed to set last modified

It's happening with a build configuration I added recently. All other build configurations are still working fine, only this one fails.

    OS: Windows 7 SP1 32 bits with all the latest updates
    Team City Version: Professional 6.5.5 (build 18087)
    VCS: Subversion, working copy format 1.6, using the latest Tortoise SVN 1.6.x
    Attached build agent log; the error started happening today around 11:54
Any hints on troubleshooting this?

Comment actions Permalink


Still happening. Tried...

  • Cleanup (from Administration page) + Reset (the server is almost always hibernated)
  • Checking "Clean all files before build"
  • Freeing as much disk space as possible in the server (it now has about 50 free GB)

I'm getting looooooooots of warnings like this one before the error, and in other builds as well, but they don't fail: Failed to delete empty directory: C:\TeamCity\buildAgent\temp\buildTmp\nunit20\ShadowCopyCache\3320_634568680693797656
I googled it but most people said I should ignore it. Could it be related to this problem I'm experiencing?

Comment actions Permalink

Well, it seems the "Error while applying patch" error is not related to the "Failed to delete empty directory" warnings. I can confirm this because I made a backup, stopped the server and went to delete everything inside that directory. I could delete everything right away, except for the nunit20 directory. I used Process Explorer from SysInternals to see which process was interfering. And was I surprised to see LOTS of nunit-agent.exe instances, each with a handle to the nunit20 directory.

I killed them all, and finally deleted the directory. I restarted Windows, Team City started just fine, no build configs or settings lost. I started some build, and YES! The warnings were gone.

But I still can't get a particular build configuration to work, and yes, it's the one with the original problem. And yes, the error message is exactly the same.
So now I'm really stumped...


Please sign in to leave a comment.