Trouble with dotCover and MSTest in TeamCity

dotCover seems to be having trouble creating snapshots in teamCity. I can "Cover All Tests from Solution" in Visual Studio from the plugin and it runs without issue. Anybody have any idea what's happening here?

Process exited with code -2


This is being run as the only step in a build config using the MSTest runner. The test assembly is listed in the assemblies include list in teamCity and that's the only configuration specified other than the required path to MSTest.

Build 'Project :: test it' #23 Started 'Mon Mar 12 15:56:36 PDT 2012' on 'Win32BuildAgent' by 'Project :: build it, build #11' Finished 'Mon Mar 12 15:58:32 PDT 2012' with status 'NORMAL Tests passed: 39' TeamCity URL http://10.0.0.7:8111/viewLog.html?buildId=256&buildTypeId=bt12 TeamCity server version is 7.0 (build 21241) [15:56:33]: bt12 [15:56:33]: Checking for changes [16:03:39]: Publishing internal artifacts [16:03:40]:      [Publishing internal artifacts] Sending build.start.properties.gz file [16:03:39]: Clearing temporary directory: C:\BuildAgent\temp\buildTmp [16:03:39]: Checkout directory: C:\BuildAgent\work\58e6b70c9606ba6b [16:03:40]: Repository sources transferred [16:03:39]: Updating sources [16:03:40]: Build preparation done [16:03:40]: Starting: C:\BuildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe #TeamCityImplicit [16:03:40]: in directory: C:\BuildAgent\work\58e6b70c9606ba6b [16:04:05]: JetBrains dotCover Console Runner v1.2.352.19. Copyright (c) 2009-2012 JetBrains s.r.o. All rights reserved. [16:04:05]: [16:04:18]: Coverage session started [3/12/2012 4:04:18 PM] [16:04:28]: Microsoft (R) Test Execution Command Line Tool Version 10.0.30319.1 [16:04:28]: Copyright (c) Microsoft Corporation. All rights reserved. [16:04:28]:      [16:04:28]: Loading C:\buildagent\work\58e6b70c9606ba6b\client.project.core.unittests\bin\debug\client.project.core.unittests.dll... [16:04:31]: Starting execution... [16:04:37]: [16:04:37]: Results               Top Level Tests [16:04:37]: -------               --------------- [16:04:37]: Passed                Client.Project.Core.UnitTests.RodFamilyTest.ShouldCreateFamilyWithRods ... [16:04:38]: Passed                Client.Project.Core.UnitTests.RodFamilyTest.ShouldOnlyHaveTransitionalRods [16:05:04]: 39/39 test(s) Passed [16:05:04]: [16:05:04]: Summary [16:05:04]: ------- [16:05:04]: Test Run Completed. [16:05:04]:   Passed  39 [16:05:04]:   ---------- [16:05:04]:   Total   39 [16:05:04]: Results file:  C:\BuildAgent\temp\buildTmp\tmpEF52.tmp.teamcity.trx [16:05:04]: Test Settings: Default Test Settings [16:05:33]: Coverage session finished [3/12/2012 4:05:33 PM] [16:05:34]: Coverage session finished but no snapshots were created. [16:05:34]: ##teamcity[importData id='mstest' file='C:\BuildAgent\temp\buildTmp\tmpEF52.tmp.teamcity.trx'] [16:05:34]: Importing data from 'C:\BuildAgent\temp\buildTmp\tmpEF52.tmp.teamcity.trx' with 'mstest' processor [16:05:34]: Process exited with code -2 [16:05:34]: MSTest report watcher [16:05:34]:      [MSTest report watcher] Watching paths: [16:05:34]:      [MSTest report watcher] C:\BuildAgent\temp\buildTmp\tmpEF52.tmp.teamcity.trx [16:05:34]: MSTest [16:05:34]:      [MSTest] Found 39 test definitions. [16:05:34]:      [MSTest] Client.Project.Core.UnitTests.RodFamilyTest.ShouldCreateFamilyWithRods ... [16:05:34]:      [MSTest] Client.Project.Core.UnitTests.RodFamilyTest.ShouldOnlyHaveTransitionalRods [16:05:34]:      [MSTest] 39 test(s) were reported [16:05:34]: MSTest report watcher [16:05:34]:      [MSTest report watcher] 1 report found for paths: [16:05:34]:      [MSTest report watcher] C:\BuildAgent\temp\buildTmp\tmpEF52.tmp.teamcity.trx [16:05:34]:      [MSTest report watcher] Successfully parsed [16:05:34]:           [Successfully parsed] 1 report [16:05:34]:           [Successfully parsed] C:\BuildAgent\temp\buildTmp\tmpEF52.tmp.teamcity.trx [16:05:35]: Waiting for 1 service processes to complete [16:05:35]: Publishing internal artifacts [16:05:35]:      [Publishing internal artifacts] Sending build.finish.properties.gz file [15:58:33]: Build finished

Please sign in to leave a comment.