Cannot run Sikuli script via Windows build agent

Hi

I have a Sikuli/JRuby script I am trying to use to drive some native Windows applications for some front end acceptance tests.

The script works fine when I run it manually from the command line using the code in the workspace the build agent has cloned and manages (under C:\BuildAgent\work\....).

I have defined the same PATH variable in the build parameters section as I have running from the command line manually.

When I try to run the script from TC via the Windows build agent, the first native application launched by Sikuli never appears and the test times out waiting for it and fails.  

I am running the Windows environment on a hosted VM and I remote in via RDP.  It appears there is something about the way the TC build agent is running the Sikuli/JRuby script such that the native applications launched by Sikuli never appear on the screen.

Can anyone shed any light on why this might be happening?

I have looked in the agent log files and can't see anything obvious in there...

Many thanks

Ben

3 comments
Comment actions Permalink

BTW - we yesterday upgraded to TC7 from 6.5 in case that might have any impact.  We didn't have this script running under 6.5 (we only tried setting it up in CI today).

0
Comment actions Permalink

Hi Ben

By default build agents are installed as system services.
By security reasons Windows does not allow these processes to access user desktop and perform UI automation tasks.
You will need to run build agents in alternate way. You can launch them interactivelly within user session by agent.bat tool.

0
Comment actions Permalink

I love you.

THank you sooo much!

0

Please sign in to leave a comment.