Eclipse 4 plugin

Hi,

We're trying to upgrade our Eclipse version to 4.1.2, but it looks like Eclipse 4 is not compatible with the teamcity plugin. When trying to install the plugin, we get the following error message:

Cannot complete the install because one or more required items could not be found.
    Software currently installed: JetBrains TeamCity Plugin 5.1.0.13430 (jetbrains.teamcity.feature.feature.group 5.1.0.13430)
    Missing requirement: JetBrains TeamCity Plug-in 5.1.0.13430 (jetbrains.teamcity.core 5.1.0.13430) requires 'bundle org.eclipse.update.core 0.0.0' but it could not be found
        Cannot satisfy dependency:
            From: JetBrains TeamCity Plugin 5.1.0.13430 (jetbrains.teamcity.feature.feature.group 5.1.0.13430)
            To: jetbrains.teamcity.core [5.1.0.13430]



Do more recent versions of teamcity support Eclipse 4? (We're currently using TeamCity Enterprise 5.1.2 (build 13430))
Or is there any plan to support Eclipse 4 in the (near) future?

Thanks,

Chris.
3 comments
Comment actions Permalink

Hi Chris,

We don't support Eclipse 4.0 yet.
Please vote for http://youtrack.jetbrains.com/issue/TW-20759 issue.
I think support will be in 7.1 or later.

0
Comment actions Permalink

Thanks Vladislav,

I've justed voted for it, that adds up to a total of 1 vote for this issue ...:_| ...

Chris.

0
Comment actions Permalink

Hi Chris

Votes are not the only factor. Of course, new platform support is a priority task for us.

Michael

0

Please sign in to leave a comment.