Service Messages are ignored by TeamCity

Hi,

I am trying to print some 2000 service messages by using cat filename.txt command on bash so that teamcity picks it up. all thease service messages are in the form of test case pass/fail:

##teamcity[testStarted name='TestStep1']
##teamcity[testFinished name='TestStep1']

But when I browse through the tests tab in the build that is completed by teamcity I see following for many of the messages:

OK <unknown test name>
OK TestStep1

TestStep1 does not bother me but <unknown test name> does.

I have tried to do a cat on shorter files subsequently but did not help (I tried to do a cat on files with 100 messages in it in a loop untill all the messages are printed). Also I tried to do cat for each file on a seperate bash but this also did not help.

Does anyone have an idea what is happening. Why is TeamCity reporting "<unkbown test name>". On the other hand I have cross checked that all the messges are in accurate format and should actually be reported on TeamCity so that the name os the test step is also printed.

Please sign in to leave a comment.