Maven build issue on Teamcity

Hi..
I am newbie to Teamcity and using it for the first time.
I am having problem while running maven build on Team city ( version - 5.1.4 (build 13550) ), it is getting stuck at a point where it is trying to do svn update.

Strangely it is not throwing any error log or exception which might indicate the issue, it remains on that step forever and eventually ends up timing out the build.

Firstly i thought it might be issue with the svn update, but the manual svn update on the team city server worked fine.

can anyone please advise on what can be the issue here, as all the builds were runnign fine previously and there haven't been any changes done to configuration which might impact this set up.

Below is the log on teamcity where it stucks:
"
[10:46:12]: [VCS Root: DNA auth-bridge Root] checkout rules: trunk=>; -:tags; revision: 146540_2012/05/18 10:45:47 +0100
[10:46:12]: [VCS Root: DNA auth-bridge Root] Will use fast SVN update "


Thanks
Rohit

3 comments
Comment actions Permalink

Hi Rohit

Could you also post teamcity-vcs.log please, it should contains additional info there.

Thanks

0
Comment actions Permalink

Thanks For your response Michael...

I looked for the log file you mentioned but it seems the file is not updated for long time.... :(
Last update was couple of years back ...

Thanks
Rohit

0
Comment actions Permalink

The problem is resolved now... there was connectivity issue with the maven repository of the build.


Thanks
Rohit

0

Please sign in to leave a comment.