plugin installation not working (7.0.1 & 7.0.3)

I have been unable to install the cmake-runner plugin with Team City 7.0.3.  Not sure if I am doing something wrong or if there is a bug in 7.x.  I've followed the instructions on the Plugin page but the zip files are not getting recognized and installed.  I tried to install a second plugin to see if there was something wrong with the cmake-runner, but neither were recognized.

Following the instructions, the zip files were placed in the <TeamCity Data Directory>/plugins directory:

     Directory of c:\TeamCity\.BuildServer\plugins
  31-May-2012   4:02:28p        <DIR>     .
  31-May-2012   4:02:28p        <DIR>     ..
  10-May-2012   4:52:14p         70,604   cmake-runner.zip
  31-May-2012   4:01:38p         11,406   compressFiles.zip



There is no indication in the teamcity-server.log of anything being found there:

[2012-05-31 16:02:53,167]   INFO - rver.plugins.PluginManagerImpl - Scanning plugins folders
[2012-05-31 16:02:53,172]   INFO - .plugins.files.JarSearcherBase - Scanning plugin folder: C:\TeamCity\webapps\ROOT\WEB-INF\plugins
[2012-05-31 16:02:56,160]   INFO - .plugins.files.JarSearcherBase - Scanning plugin folder: C:\Users\<user>\.BuildServer\plugins
[2012-05-31 16:02:56,165]   INFO - rver.plugins.PluginManagerImpl - Found 60 plugins: [agent-system-info (ver:21424), agent.push (ver:21424), Ant (ver:21424), Apache Ant (ver:21424), artifactsSizeStatistics (ver:21424), assembly-info-patcher (ver:21424), bugzilla (ver:21424), buildDurationStatisticsPlugin (ver:21424), changeViewers (ver:21424), clearcase (ver:21424), cloud-amazon (ver:21424), commandLineRunner (ver:21424), coverage (ver:21424), cvs (ver:21424), dotnet-tools (ver:21424), dotNetRunners (ver:21424), Duplicator (ver:21424), email (ver:21424), environment-fetcher (ver:21424), feed (ver:21424), FxCop (ver:21424), gant-tool (ver:21424), GAntRunner (ver:21424), gradle-runner (ver:21424), idea-tool (ver:21424), Inspection (ver:21424), Ipr (ver:21424), jabber (ver:21424), Java Crashed detector (ver:21424), java-dowser (ver:21424), jetbrains.git (ver:21424), jira (ver:21424), jps-tool (ver:21424), jvm-update (ver:21424), ldap (ver:21424), maven-tool (ver:21424), Maven2 (ver:21424), maven3-tool (ver:21424), mercurial (ver:21424), nuget (ver:21424), perfmon (ver:21424), perforce (ver:21424), powershell-runner (ver:21424), priority-queue (ver:21424), rake-runner (ver:21424), remoteAccess (ver:21424), rest-api (ver:21424), rest-api-6.0 (ver:21424), searchBuildByNumber (ver:21424), stacktraces (ver:21424), starteam (ver:21424), svn (ver:21424), swabra (ver:21424), tfs (ver:21424), usage-statistics (ver:21424), vault-vcs (ver:21424), vss (ver:21424), WindowsTray (ver:21424), xml-report-plugin (ver:21424), youtrack (ver:21424)]



Any ideas?
1 comment
Comment actions Permalink

problem solved.

I was installing the plugins in the incorrect directory....I was using the server directory and not the data directory.

0

Please sign in to leave a comment.