command line runner starts executable but stops it immediately

Hi all,
i am starting the command line runner as a build step which is responsible for collecting the build artefacts and building an installer (QSetup from Pantaray Ltd.). The problem is, i can see the tool (Composer.exe) in the task-manager for mabe 3 seconds and then it disappears as if it would have been killed by the command line runner. It doesn't run through. That would take at least 20 secs or so. Furthermore, the executable does usually have a window. This doesn't show up as well.

That's what i can read in my log:

[13:36:51]Step 6/6: Compose files (Command Line) (5s)

[13:36:51][Step 6/6] Starting: C:\Windows\system32\cmd.exe /c Composer.exe C:\TeamCity\buildAgent\work\AxonPro\Successor\Setup\AXONRelease.qsp /compile /exit
[13:36:51][Step 6/6] in directory: C:\TeamCity
[13:36:57][Step 6/6] Process exited with code 1
[13:36:57][Step 6/6] Step Compose files (Command Line) failed

If i take above command line:
C:\Windows\system32\cmd.exe /c Composer.exe C:\TeamCity\buildAgent\work\AxonPro\Successor\Setup\AXONRelease.qsp /compile /exit
and start it manually from a command prompt, it runs perfectly. The window comes up, the whole process takes around 20 seconds, the window closes, the installer-file has been built and ready.

I had this build step previously in an msbuild script. But this didn't work either. It all worked well on our old build server V6.5 build (17795). Now we had to use a new machine and TeamCity V7.0.3 (build 21424) has been installed on a 64-bit Win7. Configuration of the project in TC is completely the same.

That's what i tried as well:
- use the working directory setting and made sure, Composer.exe is located there
- moved Composer.exe into a directory without any spaces in it's name
- renamed Composer.exe into something else and referenced this new name
- running this from an MSBuild script. But problems were even harder to nail down there.
Actually useless, as Composer.exe is definitely being started. I can see it in TaskManager.

Any idea what's going wrong here?

Greetings from Bavaria,

Harry

1 comment
Comment actions Permalink

Harald,

Most probably the issue is with the tool being invoked and the environment TeamCity agent runs in.

Please consult a dedicated section in our documentation on alike issues. Most probably the issue is either in the Windows service limitations or the OS user used to run TeamCity agent.

0

Please sign in to leave a comment.