Error after upgrading from 7.0.3 to 7.1.1 : Missing VCS Plugin on Agent

Hi,
I followed the upgrade steps from  http://confluence.jetbrains.net/display/TCD7/Upgrade

and, after upgrading to 7.1.1,  it seems that VCS plugin are not correctly installed on agents

I've tried to solve taking inspiration from  http://devnet.jetbrains.net/message/5278534#5278534
without success.
I've also reinstalled some agents from scracth but it seems not to solve too.

We  have the same problem in differente agents (automatically or manually upgraded)

You can find  some log from one of the agent in the attachement.

Maybe I'm doing something worng and you can help me.

Thanks
Domenico



Attachment(s):
logs.zip
3 comments
Comment actions Permalink

Ok I then reinstalled the server: 7.1.1 to 7.1.1 and the problem seems to be solved...

[Edit]
After installing a new agent  got the same problem :

Missing VCS plugins on agent: Team FoundationServer

Thanks
Domenico

0
Comment actions Permalink

Hi Domenico

Could you please post logs from such new agent.

0
Comment actions Permalink

Hi Michel,
unfortunately i have no logs of that agent anymore. You can have a look at the zip I attached while opening the thread (where in upgrade.log you can see no mention of tfs plugin)

Due to this instability I've decided to clean up both agents and server :

1.I've uninstalled both server and agents and removed everything from the filesystem  -in the previous attempt I haven't clean up the file system on the server-

2.I've installed 7.0.3  server and restored teh confinguration from a Backup.

3.I've installed all agents and checked that everything was ok.

4. I've disabled and stopped all agents and deleted the plugins from each agent

4.I've upgraded the server to the 7.1.1

5.I've restarted all the agents

Result:
everything is fine now in each agent


Thanks
Domenico

0

Please sign in to leave a comment.