Solved --- Configure Ruby and Rake with TeamCity

Hi ,
I am trying to use TeamCity 7.1 with Rake to build my .net MVC applications, but I am having trouble configuring TC to locate Ruby. I know very little about Ruby and can't be sure I have it installed correctly.
The message I get from TC is 'Cannot start build runner: Ruby interpreter '' doesn't exist or isn't a file or isn't a valid RVM interpreter name.'

I have scoured the Internet and the TC docs for a couple of days and tried various Rake options in the TC build step but cannot find any guidance. So I'm sure it is something simple that I am missing.

I have Ruby installed at c:\Ruby193 and if I run '"which ruby" in my gitbash shell I get /c/Ruby193/bin/ruby

But I dont have a clue about RVM interpreters etc...

Could someone please point me to a step by step guide to configuring TC to work with Rake and especilly how to install and setup Ruby correctly as this seems to be what TC is unhappy about.

Thanks in advance for any help


J

--- Solution ---

For anyone having the same problem the solution is simple.... I didn't have the .exe extension on my ruby interpreter path!!!
Nowhere did I see an example of this important configuration setting in the docs or online.

So if you want to use rake open a shell and use the $ which ruby command   and you will see somthing like this /c/Ruby193/bin/ruby but this is a linux path the windows equivalent and the path you need to enter int the Path to interpreter: config setting is c:\Ruby193\bin\ruby.exe

Easy when you know how.

Hope this helps someone :)

1 comment
Comment actions Permalink

See solution in post

0

Please sign in to leave a comment.