TeamCity refuses to use Windows NTLM authentication

Hi all,

I am trying to setup TeamCity to use Windows NTLM authentication, but it appears it ignores my changes.. I have followed the instructions, and cut and pasted the following into main-config.xml (in the data directory)

<auth-type>
    <login-module />
    <!-- Welcome message displayed to users on login form -->
    <login-description>Welcome to IR TeamCity, your team building environment!</login-description>
    <!-- Whether anonymous "view-only" logins are allowed (true|false) -->
    <guest-login allowed="true" />
</auth-type>



I have restarted the server (presumably that's what I need to do) and also rebooted just in case.. but every time the login comes back with the login which seems to only accept the original TeamCity admin login. If I login with any domain login, it says "Username or password doesn't match"

It does not disply the "Welcome to IR TeamCity, your team building environment!" line which is specified above, which is suspicious.

It is a fresh Windows 2008 server VM, with only TeamCity installed...

The login page is "/login.html"

Any clues as to why this would be happening? It's as if it's ignoring the change in main-config.xml. Is there a log file I can look at to see if it's picking up (and maybe ignoring) the change?

I'm pullng my hair out trying to figure out this supposed simple step!

This is Version 7.1.2 (build 24170).

Thanks in advance for any tips!

cheers,
Chris.
1 comment
Comment actions Permalink

The log to соусл for errors is teamcity-server.log.
Also please check that default setting

<login-module />


is removed from the config file.

0

Please sign in to leave a comment.