Default Private Key and Git authentication

Hi there,

I'm trying to set up a VCS root to pull our repository from GitHub.

I have logged in to our build server using the appropriate user account and set up an SSH key pair and configured it in GitHub. I can clone the repository to that machine. I'm using the same domain account that the TeamCity and Build Agent services run as. That should be cool right?

When I attempt to test the connection using the Default Private Key setting I see the following in the log:

(With 'Ignore Known Hosts Database' checked):

[2011-07-20 14:48:59,984]   WARN [on=editVcsRoot ] -      jetbrains.buildServer.VCS - Error occurred in test connection
jetbrains.buildServer.vcs.VcsException: Connection test failed: com.jcraft.jsch.JSchException: Auth fail


(and with 'Ignore Known Hosts Database' unchecked):

aused by: org.eclipse.jgit.errors.UnsupportedCredentialItem: ssh://git@github.com:22: The authenticity of host 'github.com' can't be established.
RSA key fingerprint is 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48.
Are you sure you want to continue connecting?
     at jetbrains.buildServer.buildTriggers.vcs.git.Settings$AuthSettings$1.get(Settings.java:271)


The second output looks more promising but I have already added github.com to the known_hosts file for that user. It suggests to me that the build agent is using a different account to the one I'm using... but the agent runs in the context that the service runs in no?

Anyway any help in diagnosing my problem would be much appreciated...

Thanks in advance

Andrew

1 comment
Comment actions Permalink

Hi Andrew,

Did you ever get this sorted?

I'm trying to set up a VCS root also but it's giving  me hell.

At the moment I'm using "Private Key" instead of "Default Private Key". Should I be using one instead of the other?

Cheers
Andrew

0

Please sign in to leave a comment.