NuGet pack fails

Failing to build NuGet pack.
When the build step succeds but step 2 (NuGet Pack) fails:

[Step 2/2] pack: Create NuGet package from Server\MVCWeb\MVCWeb\MvcWeb.csproj

[11:24:13][pack] NuGet command: C:\TeamCity\buildAgent\tools\NuGet.CommandLine.2.2.1.nupkg\tools\NuGet.exe pack C:\TeamCity\buildAgent\work\ed1bc8e38112496b\Server\MVCWeb\MVCWeb\MvcWeb.csproj -OutputDirectory C:\TeamCity\buildAgent\work\ed1bc8e38112496b\build\packages -BasePath C:\TeamCity\buildAgent\work\ed1bc8e38112496b\Server\MVCWeb\MVCWeb -Verbose -Version 0.45 -Properties Configuration=Pre-Release

[11:24:13][pack] Starting: C:\TeamCity\buildAgent\temp\agentTmp\custom_script2758268383831808638.cmd

[11:24:13][pack] in directory: C:\TeamCity\buildAgent\work\ed1bc8e38112496b

[11:24:13][pack] WARNING: Option 'Verbose' has been deprecated. Use 'Verbosity' instead.

[11:24:13][pack] Attempting to build package from 'MvcWeb.csproj'.

[11:24:13][pack] Unable to find 'MvcWeb.dll'. Make sure the project has been built.

[11:24:13][pack] Process exited with code 1

[11:24:13][Step 2/2] Step Build Package (NuGet Pack) failed




I belive it is because the csproj file is located at \Server\MVCWeb\MVCWeb\ instead of one path below root. So I tried to set the base path to: \Server\MVCWeb\MVCWeb\  but that doesnt help.
If I added a nuspec file It build not only the MVCWeb project but instead the whole solution. When I run NuGet localy it all works fine.

Please sign in to leave a comment.