Trying to set up Team City for first time with IntelliJ Web App but failing because of Tomcat

Hi all,

I'm trying to get a very basic set up running to prove a concept.

I have a very basic java web app created in IntelliJ that runs on tomcat 6

the structure is

trunk [test]
--.idea
--src
----com.main
------DoStuff
--test

----com.main
------DoStuffTest
--web
----WEB-INF
------web.xml
----index.jgp
--test.iml



External Libraries
--junit-4.10.jar
--jdk1.6.0_13 (including a reference to servlet-api.jar in a local tomcat folder)

This is all checked in to a basic subversion repository

When I run it through intellij it works fine and when I run the basic unit tests they run fine with Junit in intellij

however, in my set up of team city (which may not be right!) when I try and build it says

java.lang.IllegalStateException: basedir %system.global.library.tomcat.6.0.path% does not exist.

I really have no idea what is causing this to break, any ideas or help?

Thanks
1 comment
Comment actions Permalink

For those who have googled here with the same problem:

in "Build Parameters" set this system property

system.global.library.Tomcat.7.0.35.path     path to 'lib' directory of your desired version of tomcat
0

Please sign in to leave a comment.