Build Agent doesn't see installed fonts on Build machine

I am not sure if this is a bug or a misconfiguration, so I'll try here first.

We are running a build script to batch publish our .fla files. For some reason the fonts are not found, but only when we run the script through TeamCity. If I trigger the script manually while logged into the build machine the fonts are found, and the files are published properly. I'm not sure if it has to do with a Windows user issue, or an error we get when running the TeamCity build.

Build Environment:

  • Windows 7
  • TeamCity Enterprise 6.5.6 (build 18130)
  • Flash CS6


When I log into the build machine it is a different user than the build agent uses... not sure if that could be part of the issue?

When I trigger the build manually (a .jsfl script) I get no errors and everything publishes as expected (all embedded fonts are found).

When the build script is triggered by TeamCity, it completes successfully, but we get errors like this (and none of the embedded fonts are found):
[exec] java.io.FileNotFoundException: C:\Users\administrator\AppData\Local\Adobe\Flash CS6\en_US\Configuration\CodeModel\bundle-cache\bundle1\bundle.location (The system cannot find the file specified)
[15:28:10]: [exec] at java.io.FileInputStream.open(Native Method)


Our current workaround is to run the script manually, which totally defeats the purpose of having a CI system. I would love to get to the bottom of this, any helpful info is appreciated :)

Thanks
*.*   Sherri

2 comments
Comment actions Permalink

Sherri,

You can follow the related guide on investigating alike issues. Most probably this one is Windows one and not TeamCity.

Also, I'd recommend to upgrade to the latest TeamCity version (7.1.5 as of now). This won't probbaly help with your issue, but running an obsolete version when there is an update with lots of issues fixed and many improvements added seems like suboptimal.

0
Comment actions Permalink

Thanks Yegor, I tried most of the things listed in the troubleshooting link.

It was indeed a Windows problem and not a problem with TeamCity. Rebooting the machine has solved the issue. I'm not entirely sure why that fixed it, but it seems that the Windows Font Installer service didn't fire off the correct event to all currently running Windows services (or that not all Windows services reacted properly to the newly installed font event.)

Just thought I'd post the answer in case someone else runs into a similar issue.

*.*   Sherri

0

Please sign in to leave a comment.