MSBuild not finding the Visual Studio Solution.

Hello, I am new with this tool and I am having problems creating a new configuration.  I was able to log into my TFS , but when I tried to run my configuration, the Build Step to compile a Visual Studio Solution is failing.  I am getting :Build 'PDSAAdmin :: Program Build' #12 Started 'Wed Jun 19 17:33:46 PDT 2013' on 'PDSA-5MY64V1' by 'Robert Jurado'Finished 'Wed Jun 19 17:33:49 PDT 2013' with status 'FAILURE Cannot start build runner; process exited with code -42'TeamCity URL http://localhost:90/viewLog.html?buildId=12&buildTypeId=bt2 TeamCity server version is 7.1.5 (build 24400)[17:33:45]: bt2 (4s)[17:33:45]: Checking for changes (running for 17m:20s)[17:33:46]: Publishing internal artifacts[17:33:46]:  [Publishing internal artifacts] Sending build.start.properties.gz file[17:33:46]: Clearing temporary directory: C:\Temp\TeamCity\buildAgent\temp\buildTmp[17:33:46]: Clean build enabled: removing old files from C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf[17:33:46]: Checkout directory: C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf[17:33:46]: Updating sources: server side checkout (1s)[17:33:46]:  [Updating sources] Will perform clean checkout. Reason: "Clean all files before build" turned on[17:33:46]:  [Updating sources] Transferring cached clean patch for VCS root: PDSA-ADMIN[17:33:46]:  [Updating sources] Repository sources transferred: 11.37Mb total[17:33:46]:  [Updating sources] Removing C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf[17:33:46]:  [Updating sources] Updating C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf[17:33:48]: Build preparation done[17:33:48]: Starting: C:\Temp\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.MsBuildBootstrap.exe /workdir:C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf /msbuildPath:C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe[17:33:48]: in directory: C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf[17:33:49]: Failed to start MSBuild.exe. Failed to find project file at path: C:\Temp\TeamCity\buildAgent\work\de03216e03c87abf\PDSAAdmin-Main[17:33:49]: Process exited with code -42[17:33:49]: Publishing internal artifacts[17:33:49]:  [Publishing internal artifacts] Sending build.finish.properties.gz file[17:33:49]: Build finished
2 comments
Comment actions Permalink

Robert,

In build step settings where you start MSBuild you need to set Build file path option with file name of your VS solution or project.

0
Comment actions Permalink
Thank you, You are right, I was missing the Project Name with extension on the field.Robert J.
0

Please sign in to leave a comment.