TeamCity server process does not have enough permissions to write into the log files

Just (tried again to) upgrade from 7.x to 8.x and am getting this error at startup.

I tried upgrade to the eap some time back and got the same error but could never get it resolved.

The directory listed on the error page is "/var/lib/tomcat7/../logs". Really? Teamcity wants to write directly to "/var/lib/logs"? Or something inside /var/lib/logs? If so what directory?

The help page linked to from error page (http://confluence.jetbrains.net/display/TCD8/TeamCity+Server+Logs) indicates that logging can be
configured via "../conf/teamcity-server-log4j.xml". I cannot find this file from any of the tomcat7 locations.

This is all on ubuntu runnign as a war in tomcat7. Any help would be appreciated as our teamcity is now fully down.

-barry

2 comments
Comment actions Permalink

Well, I created /var/lib/log and gave it 777. And teamcity wrote its log directly in that directory (as tomcat7:tomcat7 as I suspected but was not sure).

Not such a big event, but the docs are very less than clear in this regard.

0
Comment actions Permalink

Hi Barry

it looks like you use war-package of TeamCity.
In such case you'll need to configure logging settings as explained in Installing TeamCity into Existing J2EE Container article.

0

Please sign in to leave a comment.