Running deploy-build after main build using the artifacts

Hi all,

I have the following:
1. RIA application build
2. Build deploy triggered by RIA build finish successfully
3. Test deploy
4. Production deploy

Step 1 and 2 works fine. Steps 3 and 4 should be triggered by SVN comment containing "deploy to test" and "deploy to production" respectively but I can't get it right.

I've set step 3 up like this:
1. Added same svn root as for RIA application with no check out (-:.)
2. Build step "copy to server"-script which works when run manually
3. Build trigger, trigger on changes in dependencies and look for the comment:
     +:root=K_SvnHttpsSubversionAssemblaComSvnApplicationServerLinuxWwwPlayground3;comment=^(\n|.)*?deploy to test(\n|.)*$:**
4. Artifact dependency: RIA Build last successful

The problem is that it never triggers if I commit using the comment. What am I missing?

I have also tried adding a snapshot dependency and set the artifact dependency to "Build from the same chain" but still the same thing.

Thanks!

/Kristian

2 comments
Comment actions Permalink

Kristian,

If deployment configurations 3 and 4 do not need to have sources checkouted on agent, please remove
the root and the "-:." checkout rule (as it is applied to your trigger and is very likely to be the cause)

Add snapshot dependencies from Deployments to Build (config 1) and use artifact dependencies "build from the same chain"

"Trigger on changes in dependencies" should be checked in VCS triggers in deployment configurations.

If the above wont help, I would double check the comment regexp (maybe simplify it?) and VCS root id (do you really need it there?)

0
Comment actions Permalink

I works!!! Regex was good luckily or I wouldn't be able to pick it up in a multi line comment :)

Thanks!

/Kristian

0

Please sign in to leave a comment.