How to set teamcity.git.fetch.process.max.memory

I'm getting an OutOfMemoryException during git clone/fetch. I might need to tweak the following settings:

teamcity.git.fetch.process.max.memory=7168M
teamcity.git.fetch.separate.process=true

But how?

I can use the TomCat configuration editor tool thing (tomcat7w.exe //ES//TeamCity) but I'd have assumed these settings are part of the build agent, so applying them via TomCat seems weird.

Thanks

Luke

1 comment
Comment actions Permalink

Hello Luke,

Try to follow these instruction to set internal properties for the Git process in this guide
http://confluence.jetbrains.com/display/TCD8/Git+%28JetBrains%29

Zdenek

0

Please sign in to leave a comment.