nUnit test fails NotSupportedException

I have a .net application building on team city, the issue I'm having is the tests work locally but fail through the build process.

here is the error - using nunit 2.6.2
Test(s) failed. System.NotSupportedException : The given path's format is not supported.
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
    at System.IO.FileStream..ctor(String path, FileMode mode)
    at Gavurin.GViewServices.PortableObjects.ReportAssembly.extractReportContent(List`1 content) in c:\Program Files (x86)\TeamCity\buildAgent\work\6b492f725be319d1\GViewServices\PortableObjects\ReportAssembly.cs:line 324
    at Gavurin.GViewServices.PortableObjects.ReportAssembly.ValidateReportAssembly(Boolean skipExtraction) in c:\Program Files (x86)\TeamCity\buildAgent\work\6b492f725be319d1\GViewServices\PortableObjects\ReportAssembly.cs:line 203
    at WebPlatform.Tests.SystemTests.SystemEndToEndTest() in c:\Program Files (x86)\TeamCity\buildAgent\work\6b492f725be319d1\WebPlatform.Tests\SystemTests.cs:line 164
------- Stderr: -------
16:37:42,242 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,357 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,360 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,378 WARN  [TestRunnerThread] SessionManager [(null)]- RegisterPrinciple without HttpContext, could be a test
16:37:42,422 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,428 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,438 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,521 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,527 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
16:37:42,530 ERROR [TestRunnerThread] GeographyDAO [(null)]- Some codes were requested for areatype "DnBRegion", but did not exist in the lookup table. Problem codes: [ENG]
----------------------------------------------------------------------------------------------------------------------------------------------

It looks like something is missing, not sure how to debug. Has anyone had a similar issue, any advice?

Thanks in advanced

Ryan

Please sign in to leave a comment.