SVN via NTLM problems

HiWe are using with success TC 5.x in our environment. Now I wanted to setup a new BuildServer with TC 8 and did not get this to work.
The Server should connect using NTLM to a SVN / Subversion Repository  Testing the connection I get   “Test connection failed in xxx :: Current Development (xxx) :: xxxxxx. svn: E170001: Authentication required for '<http://servername:80> VisualSVN Server'

When we switch the SVN server to Basic auth then it works, but this is not allowed.

According to this :http://confluence.jetbrains.com/display/TCD8/Known+Issues#KnownIssues-SubversionRepositoriesWithNTLMAuthorization
and this
http://confluence.jetbrains.com/display/TCD8/Configuring+Build+Agent+Startup+Properties
I added this to wrapper.conf file in D:\BuildAgent\launcher\conf  wrapper.app.parameter.7=-Dsvnkit.http.ntlm=jna  wrapper.app.parameter.8=-Dsvnkit.http.methods=NTLM,Negotiate,Digest,Basic

According to this
http://confluence.jetbrains.com/display/TCD8/Configuring+TeamCity+Server+Startup+Properties#ConfiguringTeamCityServerStartupProperties-ServerisRunViaShellScript
I also tried to set a system command line parameter
-Dsvnkit.http.methods=NTLM,Negotiate,Digest,Basic

Any other hints ?

3 comments
Comment actions Permalink

Holger,

TeamCity server also requires connecting a repository - it checks for changes, and by default perfforms checkouts on a server side.
Build agents connect to version control directly only if agent-side checkout is enabled in build configuration settings.

You additionally need to set these Java options for TeamCity server process.

0
Comment actions Permalink

Thank you, as I written before:
I also tried to set a system command line parameter     -Dsvnkit.http.methods=NTLM,Negotiate,Digest,Basic        Any other hints  ?

This is a windows service , is this the right way to set it , via the system parameter? Or is there another way ?

0
Comment actions Permalink

Holger,

The doc links noted in the quoted doc section have the instructinos on adding the parameters to the proper places depending on how you run the server and the agent.

I'd try to run the server in console and not as a service and make sure the native svn client works find from under the same account on the same machine. You can check the parametger is passed to the server OK by searching it on the Diagnostics page in JVM arguments section.

If server detects changes OK, you can use server-side checkout to eliminate necessity to work with the settings on the agent side.

Alike procedure can be used on the agent, running the agent form the command line and passing the parameters via TEAMCITY_AGENT_OPTS environment variable.

If the parameters are passed OK, credentials are OK but NTLM authentication still does not work, youi might need to enable subversion integration debug logging in TeamCity and check the logs of send those to us with detailed description of the issue reproducing and time it was done.

0

Please sign in to leave a comment.