0

grunt task is exiting with status 0 but does not finish

I'm trying to use a grunt.js task (building and cleaning a require.js based project) a part of my build process. It is starting up properly but somehow TeamCity will not let it finish. Strangely enough it will exit with a status code of 0. Also I can easily ssh into my machine and run the batch-file that I wrapped the command in with success.

Log output will look like:

[16:59:34][Step 4/4] Starting:  C:\Windows\SysWOW64\WindowsPowerShell\v1.0\powershell.exe -NoProfile -NonInteractive -ExecutionPolicy ByPass -Command - < C:\TeamCity\buildAgent\temp\buildTmp\powershell8538083257075072449.ps1
[16:59:34][Step 4/4] in directory: C:\TeamCity\buildAgent\work\8e9be3fbdb39feee\Proj.Name
[16:59:45][Step 4/4] [4mRunning "requirejs:compile" (requirejs) task [24m
[17:00:00][Step 4/4] Process exited with code 0


When I run the task manually I will geht a lot more output (i.e. listing of all the files).

I already tried using powershell, normal command line and splitting up the task in seperate tasks, all to no success.

Has anyone else ever encountered this or has any solution to this problem? Thanks!

1 comment

Please sign in to leave a comment.