TeamCity deployment fails on a particular build agent

Hi guys,

I have been given the task of troubleshooting an issue with one of  the three teamcity deployment agents we have. The server is question actually does work. Only selective projects fail when built on this server, wherein, the same build works fine on other deployment servers. I have been doing some troubleshooting and concluded it to be an issue with MS.NET but now that doesn't seem to be the case anymore. Attached are the build logs for the same deployment from the server in question (DEPLOYP01V) and the server where it works fine (BUILD2). Any help on this would be greatly appreciated. Many thanks in advance.

Regards,

Karthik



Attachment(s):
Success_Deploy_PSM_MSBuild.log.zip
Failed_Deploy_PSM_MSBuild.log.zip
2 comments
Comment actions Permalink

Karthik,

In the logs I sse the error happens within your GenerateEnvConfigs.cmd script.
Please try to localize it by reproducing the issue on the same machine but outside of TeamCity.
Look at Build fails or behaves differently in TeamCity but not locally for common recommendations.

0
Comment actions Permalink

Hi Michael,

thanks for your response. It turned out to be a deployment specific issue. We use CodeSmithConsole which was not setup on the server. I installed the same and retried but still no luck. When I tried accessing the codesmithconsole.exe by just double-clicking to see if there are any issues with the setup, it couldn't even start. Eventviewer suggested that it's looking for .Net Framework 1.1 which I didn't install on the server (it had 2, 3.5 and 4). So I installed the same and restarted the server. When I retried, it worked like a song. Happy days!

0

Please sign in to leave a comment.