Perforce: Sync becomes very slow due to StreamGobbler spamming

When synchronizing from Perforce on a huge repository (100k files+), the stream output from the "p4 sync -f" command as used from TeamCity becomes large (10+ MB easily).
However, TeamCity consumes this stream using StreamGobbler, which seems to have some kind of limit that causes it to log a warning for every line over some limit, which makes the sync a LOT slower (3 files/second or so)

Is there a way to do either of these?
1) When syncing, pass the -q flag as well, so success messages for each file are not generated in the stream (this is 99% of the data in the stream)
2) Resize the StreamGobbler buffer to be larger

Thank you,
MM.

1 comment
Comment actions Permalink

Hello, Matthijs,

  This problem was fixed in the not-yet-released TeamCity 8.0.6, but you can install perforce plugin with the fix from here:
   http://confluence.jetbrains.com/display/TW/Perforce+Plugin

   The instructions on installing the plugin are available here: http://confluence.jetbrains.com/display/TCD8/Installing+Additional+Plugins

  Hope, this helps,
  KIR

0

Please sign in to leave a comment.