TeamCity not picking up database.properties file

Hello,

I have been using TeamCity for a while now with Internal DB and its seems to be working ok.

Now i am trying to set it up to use MSSQL, I have gone through all the documentation and changed database.properties file accordingly but when i try to start the TeamCity service, In log files, I get 'The database properties file "C:\ProgramData\JetBrains\TeamCity\config\database.properties" doesn't exist', whereas this file actually exist at tghis location.

Can someone please point me ina nay direction where i can look into to fix this problem?

Another problem i am unable to fix is 'Email Notification', i have set up email notification on build fails but get nothing when any build fail. On testing the connection, i get successful message.

Thanks
Jay

6 comments
Comment actions Permalink

I'd check TeamCity has necessary permissions to read file at this location.


0
Comment actions Permalink

Pavel, TeamCity is reading another files from same location like main.config.xml etc but errors about this file as doesn't exists.

0
Comment actions Permalink

What happens when you execute this command from command line:
notepad C:\ProgramData\JetBrains\TeamCity\config\database.properties

?

There can be typos in the file name.

0
Comment actions Permalink

Sorry, How can i execute this from command line (sorry, i have no idea how to do this. Your help will be really appreciated)

I tried

C:\>type C:\ProgramData\JetBrains\TeamCity\config\database.properties.dist
and get, all the text in my file


I have checked the path and if i copy my path till config in browser window, i go to my folder correctly.

0
Comment actions Permalink

Why .dist? TeamCity does not use .dist files, and the file mentioned in TeamCity log is without .dist suffix. .dist is just a template, you should copy it to a file without .dist suffix and then modify, you should not modify .dist file itself.

0
Comment actions Permalink

Thanks Pavel, i thought i had to keep .dist as extension. removing extension fixed my problem.

Thanks again

0

Please sign in to leave a comment.