SVN+SSH://ip connection keeps saying that it need authentication

Hi all,

I have Teamcity installed on my local machine.
Also i installed svn on my local machine.

Now i created i repo on my nas drive, but temacity cant access it.

It keeps saying: Authentication required for 'svn+ssh://ip'

I have enabled ssh on my server i created private key files thats all fine..

But i cant figure out this problem.

Iam using TeamCity 8.1 (build 29790)

Can anyone please help me with this?

1 comment
Comment actions Permalink

Hello Willem,

   Please make sure you can access your repository from the command line SSH client.

   If you're using private key file, make sure you've specifed it in the VCS Root settings, as well as username and password.
   To check VCS Root settings, use "Test connection" button.

   If it doesn't help, please attach screenshots with VCS Root settings, details of your Subversion repository setup.

   All the best,
   KIR

0

Please sign in to leave a comment.