TeamCity MSTestRunner fails: Symantec Endpoint Protection

I am running TeamCity on Server 2012 and my MSTest build runner step is failing: (Server 2012, Visual Studio 2013)

[18:40:33]Step 2/2: Run Unit Tests (MSTest) (3s)

[18:40:33][Step 2/2] Starting: C:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe #TeamCityImplicit

[18:40:33][Step 2/2] in directory: C:\TeamCity\buildAgent\work\b00779c1ff5b6b7b

[18:40:37][Step 2/2] Process exited with code 255

[18:40:37][Step 2/2] Step Run Unit Tests (MSTest) failed

When I try and run JetBrains.BuildServer.NUnitLauncher.exe #TeamCityImplicit from command prompt I get the following error:
TeamCity .NET NUnitBootstrap has stopped working (Screen Shot attached, full details below (also appears in eventViewer))
Problem signature:
  Problem Event Name: BEX
  Application Name: JetBrains.BuildServer.NUnitLauncher.exe
  Application Version: 8.0.23.0
  Application Timestamp: 527e788a
  Fault Module Name: JetBrains.BuildServer.NUnitLauncher.exe
  Fault Module Version: 8.0.23.0
  Fault Module Timestamp: 527e788a
  Exception Offset: 00005bce
  Exception Code: c0000005
  Exception Data: 00000008
  OS Version: 6.3.9600.2.0.0.272.7
  Locale ID: 1033
  Additional Information 1: 5861
  Additional Information 2: 5861822e1919d7c014bbb064c64908b2
  Additional Information 3: 01d7
  Additional Information 4: 01d7340064827245f2249cd1f1a7c264

  • I am running the following .net framework on this server


Microsoft (R) .NET CLR Version Tool  Version 4.0.30319.18020
Versions installed on the machine:
v2.0.50727
v4.0.30319

I can run the following from command prompt:
JetBrains.BuildServer.NUnitLauncher2.exe

Can Anyone help me understand WHY???



Attachment(s):
Capture.JPG
1 comment
Comment actions Permalink
UPDATE: SYMANTEC AV is somehow blocking Team City from running the NUnitLauncher.exe

Uninstalled Symantec SEP and this works but we can't run this way, tried adding SEP exceptions: still no go

Maybe related? http://devnet.jetbrains.com/message/5468665
0

Please sign in to leave a comment.