Github service hook not using the right branch name

I have github push a notify to TeamCity (8.1) when there's a change. That part works great. Part of the issue is that the branch is set to "master" in the service hook. Then in TeamCity I have "master" as the name of the default branch. But TeamCity seems to think those are different. I have a bunch of commits under "Pending". If I run Run then the pending changes go away, the only difference that I can see is that the branch name is <default> instead of master. It's related to http://youtrack.jetbrains.com/issue/TW-30609 (I made a comment there). The workaround that was suggested in that ticket didn't work for me. Note that I also have a snapshot dependency set up, not sure if that's what messes it up. Please see the attached image.

TeamCity.PNG

So GitHub is updating the project called "Deployment", which has a snapshot dependency on "Build". See how I have all these changes under the Build project. But the proper commits gets built, it's just that it displays them as pending. Plus I think the branch name is in a lighter color than when I hit Run (the 2nd line in the image is when I run Run on the Deployment project).

/Hakan

Please sign in to leave a comment.