Can no longer connect to visual studio online (TFS)

As of yesterday afternoon (Tue, Mar 18th), our Team City instance can no longer connect to visual studio online. It just stopped working. We tried retsrating the entire server, team city agents, etc. to no avail. I did see Microsoft did an update on their end yesterday. Anyone else having issues or a solution? We are able to access our visual studio online projects fine with the account we are using in the Team City config.  We are able to access them through Team Explorer, as well.  Below is the error we are getting on all projects:

TF30063: You are not authorized to access xxxxxxx.visualstudio.com\DefaultCollection.   

We also tried upgrading to latest Team City (8.1.1), but still doesnt work. Help!

3 comments
Comment actions Permalink

We are facing the exact same issue that occurred around the same time!

Have you found a solution yet? Everything was working just fine and now it's just showing that user is not authorized (WTF)... We are also on 8.1.1.

0
Comment actions Permalink

Found the solution. Apparently, Microsoft (without warning) changed the password requirements for Basic Authentication. So, if the basic authentication account password requirements dont meet the new requirements, you will have this problem. We changed our password to meet the new requirements, and everything started working.  Below is the email from Microsoft:

I’ve found that we have updated our Basic Authentication rules for VSO. Passwords there must now have at least 8 characters and contain at least three of the following: uppercase letters, lowercase letters, numbers, and symbols.


If your connection uses the VSO Basic Auth feature, please update your password in VSO and in your app and try again.

0
Comment actions Permalink

Lifesaver! Thanks so much.. It's back up and running for us again.

0

Please sign in to leave a comment.