List remote refs failed: org.eclipse.jgit.errors.UnsupportedCredentialItem

I have GIT installed on a Linux server, and I can use GIT on Windows through GIT Bash using ssh.

Now which method shall I use and where is the instruction, to create a "New VCS Root" to connec to the GIT server on Linux? I alway getting this error, no mater which choice:

List remote refs failed: org.eclipse.jgit.errors.UnsupportedCredentialItem: ***************

Thanks

Jirong

3 comments
Comment actions Permalink

I am seeing the same error, and I've not found a way around it.

TeamCity 8.1.1 running on Mac OS X Mavericks 10.9.2
Java version: 1.7.0_51

Java VM info: Java HotSpot(TM) 64-Bit Server VM

 

Java Home path: /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/jre

TeamCity is running as the *************** user.

I cannot switch to HTTP access to git. We can use either git or ssh protocol.
Access to the git repo works from other clients, who use ssh and ssh keys.

I see this error in TeamCity logs:

[2014-04-03 10:55:54,580]   WARN [nio-8111-exec-4] -      jetbrains.buildServer.VCS - Error occurred in test connection
jetbrains.buildServer.vcs.VcsException: List remote refs failed: org.eclipse.jgit.errors.UnsupportedCredentialItem: *************** Password:


with this Fetch URL:
***************
using a custom private key
/Users/***************/.ssh/id_rsa

changing the Fetch URL to ***************
returns the same error

I think this is broken. I have not found an open ticket, tho there's a ticket listed that looks similar:  TW-31790 ssh to git@somegitserver error

0
Comment actions Permalink

I think I found more detailed error in the log and fixed it by following this: error: insufficient permission for adding an object to repository database ./object

http://stackoverflow.com/questions/6448242/git-push-error-insufficient-permission-for-adding-an-object-to-repository-datab

JIrong

0
Comment actions Permalink

Thanks. I am glad this worked for you.

I don't see how being able to push is related to the problem I'm seeing, which is what that stackoverflow entry was about. I'm not trying to push. Typically, a git server is set up to allow clone and pull without special credentials, but push does. That's how our git server is set up. Only authorized users can push, but anyone can clone, pull, checkout.

Still, it might be a good idea for me to check permissions and see if there's something amiss.

Meanwhile, I'd like to hear from Jetbrains. I have spent a lot of hours trying to solve this, and the error returned is far too cryptic.

0

Please sign in to leave a comment.