VCS - 407 Proxy authentication required

I'm running Team City 8.1.2 (build 29993) on an OS X Server virtual machine which is bridged to the host's network.

I've got this in the TEAMCITY_SERVER_OPTS environment variable set on the user's .profile file -

-Dproxyset=true -Dhttp.proxyHost=proxy01 -DnonProxyHosts=localhost -Dhttps.proxyHost=proxy01 -Dhttp.proxyUser=DOMAIN\\username -Dhttp.proxyPassword=password -Dhttps.proxyUser=DOMAIN\\username -Dhttps.proxyPassword=password

Whenever I test the VCS root connection to my extenally hosted repo (git on BitBucket), I get a 407 Proxy Authentication Required. All other network connections (i.e. browser, git, etc) work perfectly well. What am I doing wrong?

1 comment
Comment actions Permalink

Hi, we don't support proxy authentification from command line. And by setting only parameters it won't work.  

Also, the options above applies to java code executed with TC server JVM only. However, we often use native clients to access VCS: hg, perforce and TFS. Git and svn use java libraries.

0

Please sign in to leave a comment.