"WARNING: Unable to connect to the remote server" on Nuget Installer step

I'm on TeamCity Professional 8.1.1 (build 29939)
I'm getting "WARNING: Unable to connect to the remote server" on my Nuget Installer step.
When I pull the nuget packages from visual studio, it takes a couple minutes before the package list shows up.
I'm assuming this is related to why the installer step is failing.

Is there a way to extend the timeout for pulling in nuget packages?

4 comments
Comment actions Permalink

Hi,

Please attach build log and build step settings.
Can you please also run the same command (you can find it in build log) via console on the agent machine under the same user as the agent is running.
The problem is not related to timeout, because TeamCity just run nuget.exe and does not perform any additional steps.

0
Comment actions Permalink

I have attached the log of the build.
Below is the relevant command:

C:\AmsCI\TeamCity\buildAgent\plugins\nuget-agent\bin\JetBrains.TeamCity.NuGetRunner.exe C:\AmsCI\TeamCity\buildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe restore C:\AmsCI\TeamCity\buildAgent\work\dbbf572a5acb6716\AMS.Dealers.sln -NoCache -OutputDirectory C:\AmsCI\TeamCity\buildAgent\work\dbbf572a5acb6716\packages -Source https://www.nuget.org/api/v2/ -Source http://domain/httpAuth/app/nuget/v1/FeedService.svc/

I also tried running the command in cmd as administrator on the server (agent is hosted on the same server) and I get mostly the same result as the build log, except with a lot more giberish.
Ex: "eARNING: Unable to connect to the remote seUrnvaebrl" is what i mean by giberish. This is one of the more readable lines.

Some more information on the build step:
This is a nuget installer type step
Its connecting to the basic auth teamcity nuget server.
The nuget credentials build feature is added with the appropriate credentials.

I use the same credentials to access the teamcity nuget server via visual studio 2013.
As i mentioned before, visual studio 2013 takes a long time to bring up the available packages (can be 5-10 minutes).
PS: when i run the feed from firefox, i get the package list almost immediately... I don't understand why visual studio takes so long.

Ton



Attachment(s):
AmsWeb_Dealers_186.log.zip
0
Comment actions Permalink

It turns out I had needed to reference localhost rather than the domain for my private feed.

0
Comment actions Permalink

The problem was that I could not even get to the feed to pull down the packages in the first place. A good troubleshooting step would be to take the feed url that is in the configuration and run it. In this case, it would be http://localhost/httpAuth/app/nuget/v1/FeedService.svc/Packages to see if any packages come back (Firefox will format this nicely, Chrome will not). PS: I didn't use the Team City shortcut because of a different problem.

0

Please sign in to leave a comment.