Build never stop running

I have some issue right here hope you can advise us on this.

All the while application have no issue build in TeamCity, but the latest build keep building for more than 20 hours and keep on running.

We found the root cause is because we have included the document files (around 50 mb) which needed by the application. After we excluded the document files, the build is fine.

Do you think this is the network issue causing the file build need to take such a long time or you have recommendation?

log file

[04:30:15][Step 3/3] Publishing artifacts

[04:30:15][Publishing artifacts] Collecting files to publish: [D:\BuildAgent\work\da66151db2a66e7f\ESSAsia\AMD.ESSAsia.Web\obj\octopacked\AMD.ESSAsia.Web.3091.01.nupkg]

[04:30:15][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:16][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:17][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:23][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:30][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:36][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:42][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:48][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:30:54][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:31:00][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:31:06][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:31:12][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

[04:31:18][Publishing artifacts] Sending ESSAsia/AMD.ESSAsia.Web/obj/octopacked/AMD.ESSAsia.Web.3091.01.nupkg

the build not failed nor success and keep running endless.

1 comment
Comment actions Permalink

Hi,

Do you have IIS proxy configured? Please see the related issue.
If not, please attach few agent thread dumps while the build is hanging. Which version of TeamCity do you use?

0

Please sign in to leave a comment.