Filtering active builds on the Overview page not working in 8.1.x?

Hello,

We have several builds on our TeamCity overview dashboard that build all branches committed to a VCS. This way we have CI on, and can view the status of, master, branch-1, branch-2, etc all from a single VCS. This page (section) explains the use of settings to filter/hide any builds that have not been committed to within X days or built in Y hours:

http://confluence.jetbrains.com/display/TCD8/Working+with+Feature+Branches#WorkingwithFeatureBranches-Activebranches

I noticed our server was not adhering to the defaults of 7 days and 24 hours, so I manually added those configurations to the internal.properties file and restarted the service for good measure. Still no dice. I've attached a screenshot from part of the Administration => Diagnostics screen to show the internal properties that I added.

Has anyone else played with these properties and know what I might be missing, or does anyone from JetBrains know if this is an outstanding issue or broken feature in the current TeamCity build? Thanks.



Attachment(s):
teamcity_admin_diag.PNG
4 comments
Comment actions Permalink

Hi,

There are to tabs in build configuration: Branches and Overview. In Branches tab "Active branches" are displayed, on "Overview" tab you can select one specific branch or "All branches".

0
Comment actions Permalink

Thanks for your reply! Unfortunately, I know about both of those tabs and am not concerned with what is displayed on them. I am looking to hide old/inactive branches and builds on the overview.html page, which is displayed if you click 'Projects' in the top-left. This is the main TeamCity dashboard, and currently every build configuration lists the latest build of 'master' and every branch.

I am trying to set configuration values that will hide the information about the latest build of branches that have not had activity in a while, since that information clutters up the Dashboard. Hopefully this clarifies what I am looking for.

0
Comment actions Permalink

On the overview page the same active branches should be displayed as on the build configuration Branches tab. Default (master) branch is always shown on overview page.
Could you please provide screenshot of your overview page and point out which branches are incorrectly considered as active? And also screenshot of Change Log tab for corresponding build configuration and branch.

0
Comment actions Permalink

Alina,

Thanks so much for pointing me at the specific logs to review. I found that the error was in my logic because of our specific setup, and not the parameters. We have the same VCS source used in two build configurations, one which is a CI build-only configuration, and another which is used to manually build and deploy. There were branches that have not been deployed in weeks showing up on the second configuration, and I thought this was an error. However, changes are still being made in those branches, which is why the branch shows in both build configurations. I just ran some tests using different internal property values and could see the branches disappear/reappear as expected now that I am thinking about the filtering properly. Much appreciated!

0

Please sign in to leave a comment.