AssemblyInfo Patcher not stamping assemblies with specified version

Hi All,I'm kind of new to Team City and I'm trying to get the AssemblyInfo Patcher to stamp my assemblies. I've had a look at many blog posts and I believe I've setup everything correctly. In the configuration settings I have a BuildNumberFormat set to %build.Counter% and I have a Build counter set at 600 for testing purposes. In my AssemblyInfo patcher settings I have set the all version formats to be %build.number%. I have also tried %system.build.number% as well as a hard-coded value of 1.2.3. But it doesn't matter what values I add here the output assemblies always end up being stamped with what is in my AssemblyInfo.cs file.When I look at the build log there are entries stating that they are updating the assemblyinfo.cs files and then at the bottom of the log there are entries saying that the assemblyinfo files are being reverted back. So according to the log it has done it. Is there anything else I need to do to get this assemblies to be stampled correctly? Are there any other settings I need to set to get the assemblies to be stamped correctly?I'm using TeamCity Professional 8.0.5 (build 27692)Thanks in advance,Damien
3 comments
Comment actions Permalink

I'm experiencing the same issue.
Version: TeamCity Professional 8.1.5 (build 30240)

0
Comment actions Permalink

Hi,

This feature works only for "standard" projects, i.e. created by means of the Visual Studio wizard, so that all the AssemblyInfo files and content have a standard location. Is your AssemblyInfo.cs located in /properties subfolder?
Also by default AssemblyInfo Patcher scans up to 7 sub-directories. You can change this depth by setting teamcity.assemblyInfoPatcher.scanDepth configuration parameter.

0
Comment actions Permalink

I was actually able to resolve my issue.  I was capturing artifacts from the release folder. However, the MSBUILD step was performing a debug build.  

0

Please sign in to leave a comment.