Issue connecting to TFS

Hi,I have just installed TC 8.1.5 and am attempting to get it connected to our TFS server, but am getting problems.



If I use the 'Create Project from URL' button, I enter the following details:



Repository URL: http://mytfsserver/tfs/

Username: MYDOMAIN\myusername

Password: mypassword



When I click Proceed, i get the following error message:

"Failed to connect to a server by provided URL: authentication failed"



The username and password are correct, and if I put the repository URL into a browser, i can access the repository that way.



I have tried different Respository URLs such as:

http://mytfsserver/tfs/DefaultCollection

http://mytfsserver/tfs/MyPROJECT/

http://mytfsserver/tfs/MyGroup/MyProject



If I use the 'Create Project' button, and then 'Create Build Configuration', in the New VCS Root folder, the values I put are:

Type of VCS: Team Foundation Server

VCS root name: aRandomName

URL: http://mytfsserver/tfs/

Root: $/myGroup

username: MYDOMAIN\myusername

Password: mypassword



When I click the Test connection, I get an error (f2 is the name of my project):



"Connection failed!"

"Test connection failed in f2 :: f2f2. Failed to start TFS pooled process, error: jetbrains.buildServer.vcs.VcsException: Process not alive"



I have tried installing TC and the build agent as the SYSTEM user, and as my user, and get the same results with both.



I am running windows 8, with VS2013 installed.

TFS server is running TFS 2012



Any help on this would be greatly appreciated,



Thanks

4 comments
Comment actions Permalink

Some additional info from the teamcity-tfs.log file when i try to connect using the 'New VCS Root' method:

[2014-10-14 11:06:26,886]   INFO - fs.pool.PooledTfsProcessRunner - Starting new TFS pooled process
[2014-10-14 11:06:26,910]   INFO - TfsPooledProcess.pooledProcess - TFS pooled process started.
[2014-10-14 11:06:26,933]   INFO - TfsPooledProcess.pooledProcess - C:\TeamCity\webapps\ROOT\WEB-INF\plugins\tfs\bin\tfs-native.exe @@C:\TeamCity\temp\TC-TFS-62-1186_3\command.params, in file: {cli-server}
[2014-10-14 11:06:26,953]   WARN - TfsPooledProcess.pooledProcess - Unhandled Exception: System.IO.FileLoadException: Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.
[2014-10-14 11:06:27,296]   INFO - TfsPooledProcess.pooledProcess - Tfs pooled process exited
[2014-10-14 11:06:27,298]   INFO - fs.pool.PooledTfsProcessRunner - Failed to start TFS pooled process: jetbrains.buildServer.vcs.VcsException: Process not alive
jetbrains.buildServer.vcs.VcsException: Process not alive

0
Comment actions Permalink

Hi,

Are you able to connect to TFS server using Team Explorer (not using TeamCity) from the TeamCity server machine and agent in case of agent-side checkout mode?

0
Comment actions Permalink

Hi Alina,

Thanks for replying.

Yes, I can connect to TFS server in Team Explorer and Visual Studio from the machine that I am hosting TeamCity on (Agent is on this machine as well).

I am still getting the problem with auth in the 'Create Project from URL' button.
But, I have managed to get it working using the 'Create Project' button, and configuring each setting, but to get it to work I had to:

In the C:\TeamCity\webapps\ROOT\WEB-INF\plugins\tfs\bin\tfs-native.exe.config file, I had to add the following attribute to the <startup> tag:

useLegacyV2RuntimeActivationPolicy="true"

When I did this, it worked and could connect to TFS.

0
Comment actions Permalink

I've created issue in our tracker for this problem.

0

Please sign in to leave a comment.