Problems with StaticUIExtensions and CSS

I've tried using the StaticUIExtensions plugin to inject my own CSS and I'm unable to get it to work. I'm using TeamCity version 8.1.5 (build 30240) with the "latest successful" build for 8.1 found here under Ubuntu 14.04. I was unable to find a way to create an issue at this GitHub page. I am able to successfully inject HTML. I've tried using the latest versions of both Firefox and Chrome.

My static-ui-extensions.xml looks like this:
<?xml version="1.0" ?>
<teamcity-static-ui-extensions>
  <rule place-id="ALL_PAGES_HEADER" css-file="header.css">
    <url equals=""/>
    <url starts=""/>
  </rule>
</teamcity-static-ui-extensions>


When I load overview.html I see the following in the Firefox Style Editor under [large negative number].css:
/*---
/plugins/StaticUIExtensions/resources.html?token=BnH...gy1&includeFile=header.css
---*/
null


header.css (located in [...]/config/_static_ui_extensions/):
body {
  color: blue;
}


I think I'm doing everything correctly but I don't know why it's not loading.

Also, there is an error in README.md at the GitHub page. The sample rule uses the attribute "css-files" when the correct attribute appears to be "css-file". This also cost me some time :p.

Message was edited by: RotsiserMho [added info. about error in README.md]

1 comment
Comment actions Permalink

Hi,

Thank you for your feedback. I've created the issue - https://youtrack.jetbrains.com/issue/TW-39171, please watch/vote for it.

0

Please sign in to leave a comment.