Cannot deploy web project in teamcity

   Hi
In my webproject there are settings for deploy to filesystem (ToFile.pubxml):

  <PropertyGroup>
    <WebPublishMethod>FileSystem</WebPublishMethod>
    <LastUsedBuildConfiguration>Debug</LastUsedBuildConfiguration>
    <LastUsedPlatform>Any CPU</LastUsedPlatform>
    <SiteUrlToLaunchAfterPublish />
    <LaunchSiteAfterPublish>True</LaunchSiteAfterPublish>
    <ExcludeApp_Data>False</ExcludeApp_Data>
    <publishUrl>C:\Release</publishUrl>
    <DeleteExistingFiles>False</DeleteExistingFiles>
  </PropertyGroup>


and I try to publish it on step "MSBuild" with this command line:

/p:DeployOnBuild=True
/p:PublishProfile=ToFile

Buld step is success but C:\Release is empty. Why can be this? TeamCity 8.1 is running on Windows server 2007R. When it was running on my local machine there were no this problem. Could you tell me how to set publishing correctly?

6 comments
Comment actions Permalink

Hi,

Could you please try to run the build from the command line using msbuild.exe on the same machine as TeamCity agent, under the same user TeamCity agent runs under and with all the same settings? For more details please see this doc section.

0
Comment actions Permalink

hm, even under my account msbuild doesn't build my project (no files are created). But writes 0 errors. On my local machine msbuild with the same command line parameters publishes the same project successfully. Why can be this?

0
Comment actions Permalink

The issue seems more like TeamCity agent machine environment issue rather then TeamCity one. Perhaps you can add more logging to your build.

0
Comment actions Permalink

Is it possible to set manually path to msbuild.exe in bild step settings?

0
Comment actions Permalink

You can use Command Line build step to manually specify the path to msbuild.exe.

0
Comment actions Permalink

Yes, I found out myself.
So, I resolved this problem by reinstalling VS.

0

Please sign in to leave a comment.