TeamCity and NuGet Packages in SLN fails to build & paths are relative in csproj file

I am absolute new to TeamCity and tryng to get my builds...

As a Source repository i am using bitbucket and I was able to create my build project and plan without problems however i am not able to build that project without running into problems.

For a while now i try to figure out how to build this project which is hosted on Bitbucket and is using some 3rd party DLL's which were installed/added to the project through VS (2013) NuGet manager.

When i try to build it, the error message clearly says that it cannot find the dependencies. They are obviously in the GIT repository and the project file has corretc relative path files.


the structure is the following:

solution.sln
project/
     |--------solution.csproj
     |-------- ** sourcecode files & subfolders

packages/
     |------------packag1/
     |               |------------file1.dll
     |               |------------file2.dll
     |------------packag2/
     |               |------------file1.dll
     |               |------------file2.dll
     |


The hint Tag path seems correct to me:

     <Reference Include="AForge">
      <HintPath>..\packages\AForge.2.2.5\lib\AForge.dll</HintPath>
    </Reference>
    <Reference Include="AForge.Video">
      <HintPath>..\packages\AForge.Video.2.2.5\lib\AForge.Video.dll</HintPath>
    </Reference>


build errors i get:
Extensions\AForgeFilterInfoExtension.cs(1, 7): error CS0246: The type or namespace name 'AForge' could not be found (are you missing a using directive or an assembly reference?)


I googled around and searched this forum but i do not see any clear answer how to specify 3rd party dll's  ....

1 comment
Comment actions Permalink

Hi Tomek,

Please check that these assemblies are not missing on the agent. Could you please try to run the build from the command line on the same machine as TeamCity agent, under the same user that the agent is running and with all the same settings? See the related section in documentation.

0

Please sign in to leave a comment.