SMB Deployer slow copy speed

I am copying to and from Windows 2008 Servers machines.  A copy using Windows Explorer takes a few seconds to transfer a 15MB file.
The default SMB deployer settings takes 12mins for the 15MB file.
I've tried configuring these settings in my agent's wrapper.conf
wrapper.app.parameter.8=-Djcifs.smb.client.rcv_buf_size=604160
wrapper.app.parameter.9=-Djcifs.smb.client.snd_buf_size=166440
wrapper.app.parameter.10=-Djcifs.resolveOrder=DNS
wrapper.app.parameter.11=-Djcifs.smb.client.dfs.disabled=true
wrapper.app.parameter.12=-Djcifs.netbios.client.writeSize=15000

wrapper.app.parameter.13=jetbrains.buildServer.agent.AgentMain
# TeamCity agent parameters
wrapper.app.parameter.14=-file
wrapper.app.parameter.15=../conf/buildAgent.properties


Only these two configurations seem to have any effects:
wrapper.app.parameter.10=-Djcifs.resolveOrder=DNS
wrapper.app.parameter.11=-Djcifs.smb.client.dfs.disabled=true

With them copying takes about 5mins.
Each time I make changes to wrapper.conf, I restart the build agent service.

Have I miss configured something? Thanks.

1 comment
Comment actions Permalink

Tam,

Thank you for the comprehensive report.
Please update the Deployer plugin to latest version, it includes "Name resolution" advanced option which is equivalent to

-Djcifs.resolveOrder=DNS
-Djcifs.smb.client.dfs.disabled=true

and can be configured without agent restarts or configuration changes.

As to 5 minutes (which is still too much), please report this issue to GitHub tracker here: https://github.com/JetBrains/teamcity-deployer-plugin/issues
I will see if it possible to improve the plugin's performance.

0

Please sign in to leave a comment.