error during build with azure sdk

Hello,

During our compliation step, we're getting an error:

  • Publish 
  • MSBuild 
  • src\____.Azure\____.Azure.ccproj 
  • CopyServiceModel 
  • C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Windows Azure Tools\2.5\Microsoft.WindowsAzure.targets(3304, 5): error MSB4062: The "AddGeneratedXmlComment" task could not be loaded from the assembly C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Windows Azure Tools\2.5\Microsoft.VisualStudio.WindowsAzure.Tasks.2.5.dll. Could not load file or assembly 'Microsoft.Build.Utilities.Core, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.
  • Project src\_____\______.Azure.ccproj failed. 
  • Project src\_______.sln failed. 


Our build machine seems to have the same azure configuration as the dev machine.  Is this an azure issue or is there something in team city we should look at?

Thanks,
Scott

1 comment
Comment actions Permalink

Hi Scott,

Please have a look at this section in our documentation: https://confluence.jetbrains.com/display/TCD9/Common+Problems#CommonProblems-BuildfailsorbehavesdifferentlyinTeamCitybutnotlocally
It can help to determine where the problem is.

0

Please sign in to leave a comment.