Connecting TeamCity to VSO with Alternate creds disabled.

Hi there,

I'm exploring setting up TeamCity for a new project, and connecting to a VSO account.  For security reasons beyond my control, alternate credentials are disabled for this VSO project.  Given that, is there still a way to connect TeamCity to this project?

3 comments
Comment actions Permalink

Hi Brandon,

No, it is not possible in TeamCity now. Please watch and vote for the related feature request - https://youtrack.jetbrains.com/issue/TW-37903.

0
Comment actions Permalink

I've been able to enable alternate credentials for some temporary tests, but am still unable to connect.  Browsing older issues, it appears spaces in URL's used to be a problem, my current conjecture is that there is a dash "-" character in our repository URL, could it be possible that this is what is preventing me from creating a new project?  No matter what I do, the error i receive is "Cannot create a project using the specified URL. The URL is not recognized."

0
Comment actions Permalink

Did you specify URL to your Visual Studio Online project’s in the following format https://accountname.visualstudio.com/DefaultCollection/$/ProjectName?
For step-by-step instructions, see the related blog-post.

0

Please sign in to leave a comment.