Web Deploy tutorial issues

I've been trying to follow this tutorial for a couple of days and I just can't get it to work:

http://confluence.jetbrains.com/display/TCD8/Continuous+Delivery+to+Windows+Azure+Web+Sites+(or+IIS)

No matter what I do the artifacts are not created.  If the artifiact directory doesn't already exist in git (i.e. there's a file there) the publish fails with "directory doesn't exist."  If I manually add a single file to that directory so Team City doesn't fail on that step, the only thing that actually gets added to that directory on the agent is the dummy file I've already added there.  I've tried moving the pubxml file to the same directory structure on team city, to no avail.  The build completes successfully, there's no warning about a directory not existing, but my zip file and other settings files don't get created.

The build step looks like this:

Parameters Description
Visual Studio (sln)
Build file path: <app>.sln
Targets: Rebuild
Configuration: Release
Platform: <default>
Execute: If all previous steps finished successfully

I've added command line parameters:
/p:DeployOnBuild=True
/p:PublishProfile="dev"
/p:ProfileTransformWebConfigEnabled=False

There's a PublishProfiles/dev.pubxml located from the solution root (tried it from it's default location of App_Data/PublishProfiles first)

What am I missing here?  I just want to automate a website deployment with web deploy and team city.

5 comments
Comment actions Permalink

Hi Fred,

Have you configured the artifact path, like this artifacts\webdeploy\Development => Webdeploy?
Also I've created the task to review this section in documentation: https://youtrack.jetbrains.com/issue/TW-41515. Please vote for it.

0
Comment actions Permalink

I did.  I've also tried 2 different tutorials and quite simply cannot get an automated web deploy set up with Team City.  Each of the 3 tutorials gives different instructions.  I'm honestly amazed at the lack of standard for this.  Web Deploy isn't that new.  Is there a TeamCity web deploy task in the pipeline at all?

0
Comment actions Permalink

Unfortunately, TeamCity does not provide build runners for automatic deployment. Here is a description of the recommended approach to tackle deployment in TeamCity: https://confluence.jetbrains.com/display/TCD9/How+To...#HowTo...-SetupDeploymentforMyApplicationinTeamCity.
Also some related blog posts that can be helpful: http://www.danmusk.com/deploy-asp-net-projects-from-teamcity-with-web-deploy/, http://www.troyhunt.com/2010/11/you-deploying-it-wrong-teamcity_26.html

0
Comment actions Permalink

Thanks.  But I've read all those.  I actually figured out the issue was it doesn't work with a website, but does work with a web application.  Does anyone know what the command that actually gets run is when you right click on a website in visual studio and choose publish?  All I want to do is run that command via command line (and Team City).

0
Comment actions Permalink

same problem as Fred...

I can't find how to deploy a classical asp.net website (not a web app) to a remote iis 7 :(

 

Please help...

0

Please sign in to leave a comment.