VisualStudio 2010 TeamCity plugin - Failed to connect to server

We are using TeamCity 9.0.1. One of the developers on my team is having trouble logging in through the TeamCity Visual Studio 2010 plugin. When he tries to login he receives this error:


Failed to connect to the server http://our.internal.teamcity.server:808/: Unable to connect to the remote server

I have double/triple/quadruple checked the server URL and credentials. This appears to be specific to this developer's machine: I have tried using other developer's credentials on his machine, and the error message is the same. Also, this developer is able to use his credentials to log in from other machines.

The developer has no trouble accessing/logging into the TeamCity website through a web-browser from his machine. It's only the VS2010 plugin which is not working.

Any ideas for fixing this or tracking down the root cause of the problem?

Regards

Matt

5 comments
Comment actions Permalink

Hi Matt,

Please collect logs as described here and attach them.

0
Comment actions Permalink

Hi Alina

Is there any way I can send you the log privately?

Regards

Matt

0
Comment actions Permalink

OK, I learned to stop worrying and love the bomb. Attached is a log file from a VS2010 session where I tried (and failed) to log on from the user's machine using my own credentials.

Regards

Matt



Attachment(s):
VSTCLog2.txt.zip
0
Comment actions Permalink

Hi Matt,

Sorry for delay.
It seems like a network issue. Do you have proxy server configured? There is the following line in the log:
No connection could be made because the target machine actively refused it 127.0.0.1:34398
It seems like URL has not been resolved correctly.

0
Comment actions Permalink

Hi Alina

Thanks very much for this. Yes, some software or other had configured the usage of a proxy server running locally on the user's machine. Switching this off by changing the registry key "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable" to 0 and restarting did the trick.

Regards
Matt

0

Please sign in to leave a comment.