Nuget packages does not appear in feed - due to size?

I have a build configuration, which basically retrieves nuget packes from my source control system.

The build configuration treats all nuget packages as artifacts (*.nupkg) and publishes them to the feed.

However i have observed that some of the packages does not appear in the feed, im not sure exactly why - but it might be bcause of the size. The packages missing have a size of approximately 165 mb.

The packages shows up as aftifacts, and the buld log reports no errors.

Is there any known limits in terms of packages size? Or is there a HTTP max request length setting somewhere that needs to be set? Or is it a bug?


Kind regards

6 comments
Comment actions Permalink

Hi Kenneth,

There is no limit for package size. Please try to re-index the NuGet feed as described in this section: https://confluence.jetbrains.com/display/TCD9/Common+Problems#CommonProblems-ProblemswithTeamCityNuGetFeed.

0
Comment actions Permalink

Hi Alina

I tried to rebuild the package feed as you suggested using the buildsMetadata reset link, but without success.

I also tried to add some packages with similar sizes, and they shows up just fine - so its definately not related to size.

The packages that does not appear in the feed, has previously been deployed to a standalone nuget server without any problems, also the nuget package explorer can very the package as valid.

Are you making any validation on the packages submitted to the feed, that can rule out some packages?

Or do you have any clues that can help me figure out why my packages are not appearing.

Kind regards

0
Comment actions Permalink

What TeamCity version do you use? Please create issue in the tracker and attach teamcity-server.log (you can attach it visible to JetBrains team only).

0
Comment actions Permalink

Hi Kenneth,

Are you still having the same issue? I can't seem to get any package to show up in the feed. They are declared as artifacts of the build, but they don't get indexed for some reason. In the logs I didn't find any indication that it even tried to do so. Resetting the cache as suggested by Alina, didn't change the result. Do you have any steps in the build configuration?

Kind regards,

Janos

0
Comment actions Permalink

Hi Janos,

Have you enabled NuGet server on Administration > NuGet Feed page in TeamCity UI? 

If feed is enabled, but packages are not added to the internal NuGet feed, then please attach teamcity-server.log file.

0
Comment actions Permalink

Hi Alina,

 

I found the solution buried in a Forum. The Problem was that I was viewing my feed in the browser and not directly in Visual Studio. The Problem ceased to exist as of this monday. Thanks for the follow up!

0

Please sign in to leave a comment.