Visual Studio 2015 & TeamCity 9.1.3 issues

Hi all,

We just upgraded to VS2015, which required an upgrade to TeamCity 9.1.3 (Previously on 8.something).  I'm not sure which upgrade caused my problems...

I am attempting to compile a visual studio 2015 solution file, which contains about 12 visual studio 2015 projects in the solution.  All has been running fine previously using Visual Studio 2013.  All projects are C++ and MFC and build fine both on my personal development machine and on the build server if I remote in and do it manually inside visual studio.

I get the following:

[Step 1/2] Starting: C:\BuildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.MsBuildBootstrap.exe /workdir:C:\BuildAgent\work\949780ca1b5b7956 /msbuildPath:C:\Windows\Microsoft.NET\Framework\v2.0.50727\MSBuild.exe

[Step 1/2] MSBuild output
[13:39:35][MSBuild output] Start MSBuild...
[13:39:35][MSBuild output] 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\MSBuild.exe' '"@C:\BuildAgent\work\949780ca1b5b7956\Practice\Controls\Controls\Controls.sln.teamcity.msbuild.tcargs" C:\BuildAgent\work\949780ca1b5b7956\Practice\Controls\Controls\Controls.sln.teamcity'


...

[MSBuild output] MSBUILD : error MSB1001: Unknown switch.
[13:39:35][MSBuild output] Switch: /nodeReuse:false




The problem seems to be related to this /nodeReuse:false flag.  It's not supported by the framework 2.0 MSBuild.exe that is being executed.  It does seem to be supported by the framework 4.0 MSBuild.exe that is not being used.
So at best guess, I need to either:
1)  Get rid of the /nodeReuse flag altogether (this was not a problem before upgrading) or
2)  Use the MSBuild in the framework 4 folder.

Unfortunately I cannot find any configuration settings that let me do either of these things.  Anyone have any thoughts?  Is there something else I'm missing?

I did try making a new build step using MSBuild directly as well, but it fails with the same problem.


Thanks!
3 comments
Comment actions Permalink

Hi,

I got the same problem. Did you get a solution?

Thanks,
Torsten

0
Comment actions Permalink

Hi,

there is an Workaround for this.

Add an Agent Requirements to your Project.

Parameter Name : VS2015

Condition : exists.

 

Hope this helps

Markus

0
Comment actions Permalink

Thanks Markus, it works...

0

Please sign in to leave a comment.