Can't get Git branches to be considered Active

I have setup refs/heads/develop as the default branch, and it's showing in the project interface.
But the additional branches, no matter how I select them (+:refs/heads/master, +:*. *, +:refs/heads/*) are considered as active and don't show up in the project tab, even though they received recent commits.

Mainly, following the GitFlow pattern, I'm hoping to get the master branch displayed, and its tags, so that I can build release version from the same build I use for development.

Thanks for any tip on to get this working!

3 comments
Comment actions Permalink

I upgraded to Teamcity-9.1.3 but the problem persist.
I still don't how to get my non default branches considered as 'Active'

Thanks in advance

0
Comment actions Permalink

OK forget it, It's still not displaying all the branches with a recent commit,
but I found out that by running a build manually with the Run button, selecting the branch, TC will start to display them in the main Projects tab.

0
Comment actions Permalink

Hello,

Please see Active branch definition here. There also several parameter listed in the section, with which you can customize active branches.

0

Please sign in to leave a comment.