Duplicated Agents - help

Hey!

I'm trying build an evaluation setup.  I seem to duplicated my agents.  When I ask my server what servers I have I have:

http://teamcityhost:88/httpAuth/app/rest/agents

<agents count="5" href="/httpAuth/app/rest/agents">

<agent id="2" name="Build3120" typeId="2" href="/httpAuth/app/rest/agents/id:2"/>

<agent id="6" name="build3129" typeId="6" href="/httpAuth/app/rest/agents/id:6"/>

<agent id="1" name="galor-3363" typeId="1" href="/httpAuth/app/rest/agents/id:1"/>

<agent id="2" name="Build3120" typeId="2" href="/httpAuth/app/rest/agents/id:2"/>

<agent id="6" name="build3129" typeId="6" href="/httpAuth/app/rest/agents/id:6"/>

</agents>

This looks wrong to me.  Is there a way to remove the agents from the server?  When I try to launch an agent on our building server (agent.bat start)., I get:

[2015-11-09 13:44:37,188]  ERROR - buildServer.AGENT.registration - Agent id=null. Another agent with name "build3129"(id=6) is registered on the server. Please check you do not have two agents with the same name.

I don't have another build server running on another machine.  I've killed running versions of Java.  I've restarted the build server.

I'm having trouble seeing what the next step is.  Any suggestions?

Thanks!

John

1 comment
Comment actions Permalink

Hi John,

What TeamCity version is used?
What do you see on Agents page in TeamCity UI (connected/disconnected/unauthorized tabs)?
Could you please attach teamcity-server.log and teamcity-agent.log files?

0

Please sign in to leave a comment.